Point2d Structure

This .NET class wraps the OdGePoint2d class. This class represents points (locations) in 2D space. For more information, see Working with Basic Geometry Types.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryPoint2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Point2d : IFormattable

The Point2d type exposes the following members.

Constructors
  Name Description
Public method Point2d(Double) Constructor for the Point2d class. Creates a new point with coordinates taken from the first two values of the passed array.
Public method Point2d(Double, Double) Constructor for the Point2d class. Creates a new point with coordinates specified by the x and y values.
Top
Properties
  Name Description
Public property Coordinate  
Public propertyStatic member Origin  
Public property X  
Public property Y  
Top
Methods
  Name Description
Public method Add Returns a new point as the result of adding this point to the specified two-dimensional vector.
Public method DivideBy Returns a new point as the result of dividing this point's coordinates by the specified value.
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetAsVector Returns this point as a vector.
Public method GetDistanceTo Retrieves the distance from this point to the specified point.
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method GetVectorTo Retrieves the vector with respect to the specified point.
Public method IsEqualTo(Point2d) Checks points for equality.
Public method IsEqualTo(Point2d, Tolerance) Checks points for equality with respect to the specified tolerance.
Public method Mirror Mirrors this point about the specified 2D line.
Public method MultiplyBy Multiplies coordinates of this point by the passed value.
Public method RotateBy Rotates this point about the specified point by the specified angle.
Public method ScaleBy Scales this point by the scale factor about the specified point.
Public method Subtract Subtracts the specified value from each coordinate of this point and returns the resulting point.
Public method ToArray  
Public method ToString
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider)  
Public method ToString(String, IFormatProvider)  
Public method TransformBy  
Top
Operators
  Name Description
Public operatorStatic member Addition(Point2d, Vector2d) Addition operator for the Point2d class.
Public operatorStatic member Division(Point2d, Double) Division operator for the Point2d class.
Public operatorStatic member Equality(Point2d, Point2d) Equality operator for the Point2d class.
Public operatorStatic member Inequality(Point2d, Point2d) Inequality operator for the Point2d class.
Public operatorStatic member Multiply(Double, Point2d) Multiplication operator for the Point2d class.
Public operatorStatic member Multiply(Matrix2d, Point2d) Multiplication operator for the Point2d class.
Public operatorStatic member Multiply(Point2d, Double) Multiplication operator for the Point2d class.
Public operatorStatic member Subtraction(Point2d, Point2d) Subtraction operator for the Point2d class.
Public operatorStatic member Subtraction(Point2d, Vector2d) Subtraction operator for the Point2d class.
Top
See Also

©  Bricsys NV. All rights reserved.