DecomposeForSaveReplacementRecord Structure

This class stores the three output parameters used by the Object.decomposeForSave() method. These values relate to the replacement object if it is not a database-resident, the replacement object's identifier if it is a database-resident, and an option indicating whether XData is passed to the replacement object.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesDecomposeForSaveReplacementRecord

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct DecomposeForSaveReplacementRecord

The DecomposeForSaveReplacementRecord type exposes the following members.

Constructors
  Name Description
Public method DecomposeForSaveReplacementRecord(DBObject, Boolean) Constructor for the DecomposeForSaveReplacementRecord class.
Public method DecomposeForSaveReplacementRecord(ObjectId, Boolean) Constructor for the DecomposeForSaveReplacementRecord class.
Top
Properties
  Name Description
Public property ExchangeXData  
Public property ReplacementId  
Public property ReplacementObject  
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.