SubDMeshSetPyramid
Method
|
Creates a mesh of a pyramid.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetPyramid(
double radius,
double height,
int divLength,
int divHeight,
int divCap,
int nSides,
double radiusRatio,
int smoothLevel
)
Public Sub SetPyramid (
radius As Double,
height As Double,
divLength As Integer,
divHeight As Integer,
divCap As Integer,
nSides As Integer,
radiusRatio As Double,
smoothLevel As Integer
)
public:
void SetPyramid(
double radius,
double height,
int divLength,
int divHeight,
int divCap,
int nSides,
double radiusRatio,
int smoothLevel
)
member SetPyramid :
radius : float *
height : float *
divLength : int *
divHeight : int *
divCap : int *
nSides : int *
radiusRatio : float *
smoothLevel : int -> unit
Parameters
- radius Double
- [in] Radius of a circle inscribed in a pyramid.
- height Double
- [in] Pyramid height.
- divLength Int32
- [in] Specifies how many divisions are made along the length
direction.
- divHeight Int32
- [in] Specifies how many divisions are made along the height
direction.
- divCap Int32
- [in] Specifies how many radial divisions are made for the base
face.
- nSides Int32
- [in] Number of sides for the pyramid.
- radiusRatio Double
- [in] Ratio of major to minor radii.
- smoothLevel Int32
- [in] Level of smoothness.
See Also