MaterialRefractionComponentEquality Operator
|
Equality operator for the
MaterialRefractionComponent structure. Checks whether input
refraction components are equal.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static bool operator ==(
MaterialRefractionComponent a,
MaterialRefractionComponent b
)
Public Shared Operator = (
a As MaterialRefractionComponent,
b As MaterialRefractionComponent
) As Boolean
public:
static bool operator ==(
MaterialRefractionComponent a,
MaterialRefractionComponent b
)
static let inline (=)
a : MaterialRefractionComponent *
b : MaterialRefractionComponent : bool
Parameters
- a MaterialRefractionComponent
- [in] Left refraction component to compare.
- b MaterialRefractionComponent
- [in] Right refraction component to compare.
Return Value
Boolean
true only if the following conditions are met: * Material maps for
the refraction components are equal (both can be nullptr). *
Refraction index values are equal.
See Also