MaterialRefractionComponent Structure

This structure stores the refraction component (channel) of the material that consists of a material refraction index and material map.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GraphicsInterfaceMaterialRefractionComponent

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct MaterialRefractionComponent

The MaterialRefractionComponent type exposes the following members.

Constructors
  Name Description
Public method MaterialRefractionComponent Constructor for the MaterialRefractionComponent structure. Constructs an object with the specified refraction index of a material (see refraction indexes for different materials online).
Top
Properties
  Name Description
Public property Index  
Public property Map  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method ToString Returns an equivalent string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(MaterialRefractionComponent, MaterialRefractionComponent) Equality operator for the MaterialRefractionComponent structure. Checks whether input refraction components are equal.
Public operatorStatic member Inequality(MaterialRefractionComponent, MaterialRefractionComponent) Inequality operator for the MaterialRefractionComponent structure. Checks whether input refraction components are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.