MentalRayRenderSettingsTraitsIntegerRangeParameter
Constructor
|
Constructor for the
MentalRayRenderSettingsTraitsIntegerRangeParameter structure.
Specifies the minimum and maximum numbers of samples that are used
for the pixel shading process during rendering.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public MentalRayRenderSettingsTraitsIntegerRangeParameter(
int a,
int b
)
Public Sub New (
a As Integer,
b As Integer
)
public:
MentalRayRenderSettingsTraitsIntegerRangeParameter(
int a,
int b
)
new :
a : int *
b : int -> MentalRayRenderSettingsTraitsIntegerRangeParameter
Parameters
- a Int32
- [in] Minimum sampling rate [-3..5]. Values less than zero
enable subsampling. -3 corresponds to one sample for every 64
pixels (1/64) and 5 corresponds to 1024 samples per pixel. This
parameter must be less than or equal to the maximum (b)
parameter.
- b Int32
- [in] Maximum sampling rate [-3..5]. This parameter must be
equal to or greater than the minimum (a) parameter.
See Also