PatternDefinition Structure

This class encapsulates the data returned by the Hatch.getPatternDefinitionAt() function.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesPatternDefinition

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct PatternDefinition

The PatternDefinition type exposes the following members.

Constructors
  Name Description
Public method PatternDefinition Constructor for the PatternDefinition class.
Top
Properties
  Name Description
Public property Angle Property that represents the pattern angle.
Public property BaseX Property that represents the base x-coordinate.
Public property BaseY Property that represents the base y-coordinate.
Public property OffsetX Property that represents the offset by x-coordinate.
Public property OffsetY Property that represents the offset by y-coordinate.
Top
Methods
  Name Description
Public method GetDashes Returns a collection of values that specify the dashes in the pattern definition.
Top
See Also

©  Bricsys NV. All rights reserved.