RegionBooleanOperation Method
|
Performs a Boolean operation between this and
another region object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void BooleanOperation(
BooleanOperationType operation,
Region otherRegion
)
Public Overridable Sub BooleanOperation (
operation As BooleanOperationType,
otherRegion As Region
)
public:
virtual void BooleanOperation(
BooleanOperationType operation,
Region^ otherRegion
)
abstract BooleanOperation :
operation : BooleanOperationType *
otherRegion : Region -> unit
override BooleanOperation :
operation : BooleanOperationType *
otherRegion : Region -> unit
Parameters
- operation BooleanOperationType
- [in] Type of Boolean operation.
- otherRegion Region
- [in] Other region object to perform a Boolean operation
with.
Remarks
Possible operation
types are: * BoolUnite - unites two regions into one. *
BoolIntersect - returns the intersection of two regions. *
BoolSubtract - subtracts the region from the first one. This method
is implemented only for Spatial modeler and throws the eNotImplementedYet exception for other
modelers.
See Also