PolygonMesh(PolyMeshType, Int32,
Int32, Point3dCollection, Boolean, Boolean)
Constructor
|
Default constructor for the PolygonMesh
class.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public PolygonMesh(
PolyMeshType type,
int size,
int sizeValue,
Point3dCollection vertices,
bool closedValue,
bool closed
)
Public Sub New (
type As PolyMeshType,
size As Integer,
sizeValue As Integer,
vertices As Point3dCollection,
closedValue As Boolean,
closed As Boolean
)
public:
PolygonMesh(
PolyMeshType type,
int size,
int sizeValue,
Point3dCollection^ vertices,
bool closedValue,
bool closed
)
new :
type : PolyMeshType *
size : int *
sizeValue : int *
vertices : Point3dCollection *
closedValue : bool *
closed : bool -> PolygonMesh
Parameters
- type PolyMeshType
- [in] Polymesh type.
- size Int32
- [in] Number of vertices in the M direction.
- sizeValue Int32
- [in] Number of vertices in the N direction.
- vertices Point3dCollection
- [in] A collection of vertices for this entity.
- closedValue Boolean
- [in] Flag that specifies whether this entity is closed in the M
direction.
- closed Boolean
- [in] Flag that specifies whether this entity is closed in the N
direction.
See Also