HatchLoopTypes Enumeration
|
Determines types of hatch loops.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
[FlagsAttribute]
public enum HatchLoopTypes
<FlagsAttribute>
Public Enumeration HatchLoopTypes
[FlagsAttribute]
public enum class HatchLoopTypes
[<FlagsAttribute>]
type HatchLoopTypes
Members
Member name |
Value |
Description |
Default |
0 |
Not yet specified. |
External |
1 |
Defined by external entities. |
Polyline |
2 |
Defined by an OdGe polyline. |
Derived |
4 |
Derived from a picked point. |
Textbox |
8 |
Defined by text. |
Outermost |
16 |
Outermost loop. |
NotClosed |
32 |
Open loop. |
SelfIntersecting |
64 |
Self-intersecting loop. |
TextIsland |
128 |
Text loop surrounded by an even number of loops. |
Duplicate |
256 |
Duplicate loop. |
See Also