NurbSurfaceInsertKnotAtU Method
|
Inserts a knot at the specified u parameter.
The knot insertion doesn't modify the shape of the surface. It adds
a new row of control points in the v-direction and adjusts the
local control point's location.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void InsertKnotAtU(
double dU
)
Public Sub InsertKnotAtU (
dU As Double
)
public:
void InsertKnotAtU(
double dU
)
member InsertKnotAtU :
dU : float -> unit
Parameters
- dU Double
- [in] U parameter.
Remarks
If the surface
doesn't contain any NURBS information, the method throws the
eFail exception. If the surface's knot
multiplicity at the u parameter is bigger than the degree in the
u-direction, throws the eInvalidInput
exception. If this method is not implemented for a specific
modeler, throws the eNotImplementedYet
exception.
See Also