SectionSettingsSetGenerationOptions Method
|
Sets the generation options for the specified
section type.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetGenerationOptions(
SectionType nSecType,
SectionGeneration nOptions
)
Public Sub SetGenerationOptions (
nSecType As SectionType,
nOptions As SectionGeneration
)
public:
void SetGenerationOptions(
SectionType nSecType,
SectionGeneration nOptions
)
member SetGenerationOptions :
nSecType : SectionType *
nOptions : SectionGeneration -> unit
Parameters
- nSecType SectionType
- [in] Section type.
- nOptions SectionGeneration
- [in] Generation options.
Remarks
Available
generation options: SourceAllObjects - Section plane cuts through
all objects. SourceSelectedObjects - Section plane cuts only
through selected objects. DestinationNewBlock - Section is created
as a new block. DestinationReplaceBlock - Section replaces an
existing block. DestinationFile - Section is saved in a file.
See Also