ObjectSnapModes Enumeration

Represents object snap modes.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
[FlagsAttribute]
public enum ObjectSnapModes
Members
Member name Value Description
ModeEnd 1 Endpoint.
ModeMid 2 Midpoint.
ModeCenter 3 Center.
ModeNode 4 Node.
ModeQuad 5 Quadrant.
ModeIntersection 6 Intersection.
ModeIns 7 Insertion point.
ModePerpendicular 8 Perpendicular.
ModeTangent 9 Tangent.
ModeNear 10 Nearest.
ModeApparentIntersection 11 Apparent intersection.
ModeParallel 12 Parallel.
ModeStartpoint 13 Start point.
See Also

©  Bricsys NV. All rights reserved.