Rotates this vector by the specified angle
about the specified axis.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Vector3d RotateBy(
double angle,
Vector3d axis
)
Public Function RotateBy (
angle As Double,
axis As Vector3d
) As Vector3d
public:
Vector3d RotateBy(
double angle,
Vector3d axis
)
member RotateBy :
angle : float *
axis : Vector3d -> Vector3d
Parameters
- angle Double
- [in] Angle in radians.
- axis Vector3d
- [in] Axis of rotation.
Return Value
Vector3d
Rotated vector.
See Also