Vector3d Structure

This .NET class wraps the OdGeVector3d class. This class represents vectors in 3D space. Vector3d may be viewed as an array[3] of doubles. For more information, see Working with Basic Geometry Types.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryVector3d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Vector3d : IFormattable

The Vector3d type exposes the following members.

Constructors
  Name Description
Public method Vector3d(Double) Constructor for the Vector3d class. Creates a new vector with coordinates taken from the first three values of the passed array.
Public method Vector3d(PlanarEntity, Vector2d) Constructor for the Vector3d class. Creates a new vector in the coordinates of the plane: uAxis * vect.x + vAxis * vect.y where uAxis and vAxis are returned by plane.get(origin, uAxis, vAxis).
Public method Vector3d(Double, Double, Double) Constructor for the Vector3d class. Creates a new vector with coordinates specified by the x, y and z values.
Top
Properties
  Name Description
Public property Coordinate  
Public property LargestElement  
Public property Length  
Public property LengthSqrd  
Public property X  
Public propertyStatic member XAxis  
Public property Y  
Public propertyStatic member YAxis  
Public property Z  
Public propertyStatic member ZAxis  
Top
Methods
  Name Description
Public method Add Adds this vector to the specified vector.
Public method AngleOnPlane Returns the angle of this vector projected onto the specified plane.
Public method Convert2d Retrieves the 2D vector, in the coordinate system of the plane, corresponding to the 3D vector.
Public method CrossProduct Returns the cross product of this vector and the specified vector.
Public method DivideBy Divides coordinates of this vector by the specified value.
Public method DotProduct Retrieves the dot product of this vector and the specified vector.
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetAngleTo(Vector3d) Retrieves the angle between this vector and the passed vector.
Public method GetAngleTo(Vector3d, Vector3d)  
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method GetNormal Retrieves the unit vector codirectional with this vector.
Public method GetNormal(Tolerance)  
Public method GetPerpendicularVector Retrieves a vector which is perpendicular to this vector.
Public method IsCodirectionalTo(Vector3d) Checks whether the specified vector is codirectional to this vector.
Public method IsCodirectionalTo(Vector3d, Tolerance) Checks whether the specified vector is codirectional to this vector within a geometric tolerance.
Public method IsEqualTo(Vector3d) Checks whether the passed vector is equal to this vector. Vectors are considered equal if all coordinates of this vector are the same as coordinates of the specified vector.
Public method IsEqualTo(Vector3d, Tolerance) Checks whether the passed vector is equal to this vector. Vectors are considered equal if all coordinates of this vector are the same as coordinates of the specified vector within geometric tolerance.
Public method IsParallelTo(Vector3d) Checks whether the passed vector is parallel to this vector.
Public method IsParallelTo(Vector3d, Tolerance) Checks whether the passed vector is parallel to this vector within a geometric tolerance.
Public method IsPerpendicularTo(Vector3d) Checks whether the passed vector is perpendicular to this vector.
Public method IsPerpendicularTo(Vector3d, Tolerance) Checks whether the passed vector is perpendicular to this vector within a geometric tolerance.
Public method IsUnitLength Checks whether this vector is 1.0.
Public method IsUnitLength(Tolerance) Checks whether this vector is 1.0 within a geometric tolerance.
Public method IsZeroLength Checks whether this vector is 0.0.
Public method IsZeroLength(Tolerance) Checks whether this vector is 0.0 within a geometric tolerance.
Public method Mirror Mirrors the entity about the plane passing through the origin with the specified normal, and returns a reference to the entity.
Public method MultiplyBy Multiplies coordinates of this vector by the specified value.
Public method Negate Negates this vector by setting it to be equal to the vector (-x, -y, -z).
Public method OrthoProjectTo Retrieves a 3D vector produced by the orthogonal projection of this vector onto the plane with a specified plane normal at the plane origin.
Public method ProjectTo Retrieves a 3D vector produced by the parallel projection of this vector onto the plane with a specified plane normal at the plane origin.
Public method RotateBy Rotates this vector by the specified angle about the specified axis.
Public method Subtract Subtracts a passed vector from this vector.
Public method ToArray  
Public method ToString Returns a string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider)  
Public method ToString(String, IFormatProvider)  
Public method TransformBy  
Top
Operators
  Name Description
Public operatorStatic member Addition(Vector3d, Vector3d) Addition operator for the Vector3d class.
Public operatorStatic member Division(Vector3d, Double) Division operator for the Vector3d class.
Public operatorStatic member Equality(Vector3d, Vector3d) Equality operator for the Vector3d class.
Public operatorStatic member Inequality(Vector3d, Vector3d) Inequality operator for the Vector3d class.
Public operatorStatic member Multiply(Double, Vector3d) Multiplication operator for the Vector3d class.
Public operatorStatic member Multiply(Matrix3d, Vector3d) Multiplication operator for the Vector3d class.
Public operatorStatic member Multiply(Vector3d, Double) Multiplication operator for the Vector3d class.
Public operatorStatic member Subtraction(Vector3d, Vector3d) Subtraction operator for the Vector3d class.
Public operatorStatic member UnaryNegation(Vector3d) Negation operator for the Vector3d class.
Top
See Also

©  Bricsys NV. All rights reserved.