EdgeData Class

This class represents arrays of edge attributes for meshes and shells. EdgeData objects are optional; they can be optionally passed to WorldGeometry and ViewportGeometry when using their mesh and shell methods.
Inheritance Hierarchy
SystemObject
  Teigha.GraphicsInterfaceEdgeData

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class EdgeData

The EdgeData type exposes the following members.

Constructors
  Name Description
Public method EdgeData Initializes a new instance of the EdgeData class
Top
Methods
  Name Description
Public method GetColors Returns the array of edge colors used by this object. For more information about working with colors, see Working with Colors.
Public method GetLayers Returns the array of layers used by this object. For more information about working with layers, see Overview of Layers.
Public method GetLineTypes Returns the array of linetypes used by this object. For more information about working with linetypes, see Concept of Linetypes.
Public method GetSelectionMarkers Returns the array of edge graphics system selection markers used by this object.
Public method GetTrueColors Returns the array of edge colors used by this object. For more information about working with colors, see Working with Colors.
Public method GetVisibility Returns the array of edge visibility values used by this object.
Public method SetColors Sets the array of colors for this object. For more information about working with colors, see Working with Colors.
Public method SetLayers Sets the array of layers for this object. For more information about working with layers, see Overview of Layers.
Public method SetLineTypes Sets the array of linetypes for this object. For more information about working with linetypes, see Concept of Linetypes.
Public method SetSelectionMarkers Sets the array of selection markers for this object.
Public method SetTrueColors Sets the array of colors for this object. For more information about working with colors, see Working with Colors.
Public method SetVisibility Sets the array of visibility values for this object.
Top
Remarks
Setting an 'improper' size of any array may cause unpredictable results.
See Also

©  Bricsys NV. All rights reserved.