ProxyEntityProxyFlags Property

Property that represents the edit flags for the class associated with this proxy entity. These bit flags determine the allowable operations on this proxy entity. This property is a combination of one or more of the following: Name Value Methods enabled kNoOperation 0x0 None kEraseAllowed 0x1 erase() kTransformAllowed 0x2 transformBy() kColorChangeAllowed 0x4 setColor(), setColorIndex() kLayerChangeAllowed 0x8 setLayer() kLinetypeChangeAllowed 0x10 setLinetype() kLinetypeScaleChangeAllowed 0x20 setLinetypeScale() kVisibilityChangeAllowed 0x40 setVisibility() kCloningAllowed 0x80 subDeepClone(), subWblockClone() kLineWeightChangeAllowed 0x100 setLineWeight() kPlotStyleNameChangeAllowed 0x200 setPlotStyleName() kDisableProxyWarning 0x400 kMaterialChangeAllowed 0x800 setMaterial() kAllButCloningAllowed 0xB7F All of the above but cloning kAllAllowedBits 0xBFF All of the above

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public int ProxyFlags { get; }

Property Value

Int32
See Also

©  Bricsys NV. All rights reserved.