NurbCurve3dDataIsEqualTo Method

Checks whether this nurb curve data is equal to the passed nurb curve data.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public bool IsEqualTo(
        NurbCurve3dData a
)

Parameters

a  NurbCurve3dData
[in] Nurb curve 3d data to compare.

Return Value

Boolean
true if all of the following conditions are met: * both curves are rational (weight values applied) or not rational (weight values are not applied) * both curves are periodic (closed) or not periodic (open) * control points are equal * knot collections are equal * weight values are equal
See Also

©  Bricsys NV. All rights reserved.