ViewRoll Method

Rotates the camera by the specified amount about the eye vector.

Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void Roll(
        double rollAngle
)

Parameters

rollAngle  Double
[in] Camera counterclockwise (CCW) roll angle.
Remarks
Positive angles rotate the camera counterclockwise about the eye vector when viewed from the camera position to the target. This corresponds to a clockwise rotation of the up vector. Camera coordinates are relative to the view of a target from a camera. * The Y-axis is along the up vector. * The Z-axis (eye vector) is along the vector from the camera position to the target. * The X-axis is the cross product of the Y-axis and the Z-axis. All angles are expressed in radians.
See Also

©  Bricsys NV. All rights reserved.