View Class

This class is the abstract base class for classes that implement Viewport objects in GUI display windows. Each Viewport object consists of a collection of objects to be viewed and camera parameters that define the view. For more information, see Working with Views.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsSystemView

Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class View : RXObject

The View type exposes the following members.

Constructors
  Name Description
Public method View Default constructor for the View class. Creates a view with default values for its properties. For more information, see OdGsViewImpl::OdGsViewImpl Constructor.
Protected method View(IntPtr, Boolean) Initializes a new instance of the View class
Top
Properties
Methods
  Name Description
Public method Add(Drawable) Adds the specified scene graph to this Viewport object.
Public method Add(Drawable, Model) Adds the specified scene graph to this Viewport object.
Public method BeginInteractivity Puts this Viewport object into an interactive state.
Public method ClearFrozenLayers Thaws all Layer objects in this Viewport object.
Public method CloneView Clones this view object.
Public method CloneView(Boolean) Clones this View object.
Public method CloneView(Boolean, Boolean) Clones this View object.
Protected method DeleteUnmanagedObject
(Overrides RXObjectDeleteUnmanagedObject)
Public method Dolly(Vector3d) Translates the camera position and target by the specified camera coordinate dolly amount.
Public method Dolly(Double, Double, Double) Translates the camera position and target by the specified camera coordinate dolly amount.
Public method EnableDefaultLighting(Boolean) Enables default lighting for this view.
Public method EnableDefaultLighting(Boolean, DefaultLightingType) Enables default lighting for this view.
Public method EndInteractivity Disables the interactive mode for this Viewport object.
Public method Erase Removes the specified scene graph from this Viewport object.
Public method EraseAll Removes all scene graphs from this Viewport object.
Public method ExtentsInView Checks whether the specified WCS box is visible completely or partially inside the current view frustum.
Public method Flush Flushes the graphics pipeline and renders this Viewport object. This method should be called only during interactivity.
Public method FreezeLayer Freezes the specified Layer object in this Viewport object.
Public method GetModel Returns the Model object associated with the specified Drawable object in this Viewport object.
Public method GetModelList Returns the array of OdGsModel objects associated with this Viewport object.
Public method GetNumPixelsInUnitSquare(Point3d) Returns the display pixel density at the specified point for this Viewport object.
Public method GetNumPixelsInUnitSquare(Point3d, Boolean) Returns the display pixel density at the specified point for this Viewport object.
Public method GetSnapshot Returns the image of the current view buffer.
Public method Hide Hides this Viewport object.
Public method InitLights Associates lights with this Viewport object by traversing with the specified iterator.
Public method Invalidate Marks for refresh the entire area of this view.
Public method Invalidate(Rectangle) Marks for refresh the specified region of this Viewport object.
Public method InvalidateCachedViewportGeometry Marks for regeneration all subViewportDraw() geometry for this Viewport object.
Public method Orbit Orbits the camera about the target by the specified amounts.
Public method Pan Pans the camera by the specified X and Y values.
Public method PointInView Checks whether the specified point is visible inside the current view frustum.
Public method PointInViewport Checks whether the specified point is inside the viewport area.
Public method RemoveViewportClipRegion Removes the clipping region that was previously set with the ViewportClipRegion property.
Public method Roll Rotates the camera by the specified amount about the eye vector.
Public method Select Runs the selection procedure inside this Viewport object.
Public method SetLineweights Sets the lineweights for this Viewport object.
Public method SetView(Point3d, Point3d, Vector3d, Double, Double) Sets the camera parameters for this Viewport object.
Public method SetView(Point3d, Point3d, Vector3d, Double, Double, Projection) Sets the camera parameters for this Viewport object.
Public method Show Unhides this Viewport object.
Public method ThawLayer Thaws the specified Layer object in this Viewport object.
Public method Update Updates this view (propagates layer changes, makes device surface area for this view invalid, updates view properties, updates the viewport, sets invalid, and checks for validation flags depending on the regenAbort() call).
Public method ViewParameters Retrieves the view parameters of this Viewport object.
Public method Zoom Scales the focal length of the camera by the specified amount.
Public method ZoomExtents Scales the camera to completely include the specified WCS box inside the view frustum.
Public method ZoomWindow Scales the camera to completely include the specified screen area.
Top
See Also

©  Bricsys NV. All rights reserved.