XrefOperation Enumeration

Represents the external reference subcommands.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public enum XrefOperation
Members
Member name Value Description
XrefAttachOperation 0 Attaches an external reference file to the database or the current document in the editor if the host database is null.
XrefBindOperation 1  
XrefXBindOperation 1 Binds the external reference table records.
XrefDetachOperation 2 Detaches the external reference block by the specified block name.
XrefOverlayOperation 3 Overlays an external reference file on the database or the current document.
XrefPathOperation 4 Path specification of the external reference that is currently attached.
XrefReloadOperation 5 Reloads the external reference block by its name.
XrefResolveOperation 6 Resolves existing external references in the host database. The host database must not be the same database that is loaded in the editor.
XrefUnloadOperation 7 Unloads the external reference block by its name.
See Also

©  Bricsys NV. All rights reserved.