GeometryPolyline(Polyline, Int32, Int32)
Method
|
Introduces a polyline into the vectorization
context.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool Polyline(
Polyline value,
int fromIndex,
int segments
)
Public MustOverride Function Polyline (
value As Polyline,
fromIndex As Integer,
segments As Integer
) As Boolean
public:
virtual bool Polyline(
Polyline^ value,
int fromIndex,
int segments
) abstract
abstract Polyline :
value : Polyline *
fromIndex : int *
segments : int -> bool
Parameters
- value Polyline
- [in] Polyline.
- fromIndex Int32
- [in] Index of the first segment to be processed.
- segments Int32
- [in] Number of segments to be processed (0 indicates all
segments).
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
Remarks
The polyline may
contain varying segment widths, straight segments and arc segments.
The polyline takes on the current color. All points must be
coplanar.
See Also