Geometry Class |
The Geometry type exposes the following members.
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
ModelToWorldTransform | Property that represents the model-to-world coordinate transform matrix for the geometry. This is the inverse of the WorldToModelTransform matrix. |
![]() |
![]() |
WorldToModelTransform | Property that represents the world-to-model coordinate transform matrix for the geometry. This is the inverse of the ModelToWorldTransform matrix. |
Name | Description | |
---|---|---|
![]() |
Circle(Point3d, Double, Vector3d) | Introduces a circle to the vectorization context. |
![]() |
Circle(Point3d, Point3d, Point3d) | Introduces a circle to the vectorization context. |
![]() |
CircularArc(Point3d, Point3d, Point3d, ArcType) | Introduces a circular arc to the vectorization context. |
![]() |
CircularArc(Point3d, Double, Vector3d, Vector3d, Double, ArcType) | Introduces a circular arc to the vectorization context. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Draw | Introduces the specified object into the vectorization context. |
![]() |
EllipticalArc | |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Image(ImageBGRA32, Point3d, Vector3d, Vector3d) | Introduces an image in BGRA format into the vectorization context. |
![]() |
Image(ImageBGRA32, Point3d, Vector3d, Vector3d, TransparencyMode) | Introduces an image in BGRA format into the vectorization context. |
![]() |
![]() |
![]() |
![]() |
Mesh | Introduces a mesh into the vectorization context. |
![]() |
OwnerDraw | Draws a GDI owner draw object. |
![]() |
Polygon | Introduces a polygon to the vectorization context. |
![]() |
Polyline(Polyline) | Introduces a polyline into the vectorization context. |
![]() |
Polyline(Point3dCollection, Vector3d, IntPtr) | Introduces a polyline into the vectorization context. |
![]() |
Polyline(Polyline, Int32, Int32) | Introduces a polyline into the vectorization context. |
![]() |
Polypoint(Point3dCollection, Vector3dCollection, IntPtrCollection) | Introduces an array of points to the vectorization context. |
![]() |
Polypoint(Point3dCollection, EntityColorCollection, Vector3dCollection, IntPtrCollection) | Introduces an array of points to the vectorization context. |
![]() |
Polypoint(Point3dCollection, EntityColorCollection, TransparencyCollection, Vector3dCollection, IntPtrCollection, Int32) | Introduces an array of points to the vectorization context. |
![]() |
PolyPolygon | Introduces multiple polygons to the vectorization context. These polygons can be defined with various properties including shape, opacity, outlines, etc. It can draw multiple identical polygons and multiple different polygons at the same time. If some of the parameters are not defined, they are taken from the current SubEntityTraits properties. |
![]() |
PolyPolyline | Introduces multiple polylines to the vectorization context. |
![]() |
PopClipBoundary | Removes the top clip boundary from the clip stack. |
![]() |
PopModelTransform | Removes the top transformation from the current transformation stack. |
![]() |
PushClipBoundary(ClipBoundary) | Pushes a clip boundary to the current clip stack. |
![]() |
PushClipBoundary(ClipBoundary, AbstractClipBoundary) | Pushes a clip boundary with additional clipping information to the current clip stack. |
![]() |
PushModelTransform(Matrix3d) | Pushes a model transformation matrix for the current transformation stack. The specified transformation is concatenated to the current model transformation (which is initially the identity transform). The resulting model transformation is subsequently applied to all geometry introduced into this vectorization context, until popModelTransform() is called. |
![]() |
PushModelTransform(Vector3d) | Pushes a model transformation vector for the current transformation stack. The specified transformation is concatenated to the current model transformation (which is initially the identity transform). The resulting model transformation is subsequently applied to all geometry introduced into this vectorization context, until popModelTransform() is called. |
![]() |
PushOrientationTransform | Pushes the orientation transform behavior to the current transform stack and returns the resulting matrix. |
![]() |
PushPositionTransform(PositionBehavior, Point2d) | Pushes the position transform behavior to the current transform stack and returns the resulting matrix. |
![]() |
PushPositionTransform(PositionBehavior, Point3d) | Pushes the position transform behavior to the current transform stack and returns the resulting matrix. |
![]() |
PushScaleTransform(ScaleBehavior, Point2d) | Pushes the scale transform behavior to the current transform stack and returns the resulting matrix. |
![]() |
PushScaleTransform(ScaleBehavior, Point3d) | Pushes the scale transform behavior to the current transform stack and returns the resulting matrix. |
![]() |
![]() |
Ray | Introduces a ray into the vectorization context. |
![]() |
RowOfDots | Introduces a row of points to the vectorization context. |
![]() |
Shell | |
![]() |
Text(Point3d, Vector3d, Vector3d, String, Boolean, TextStyle) | Introduces text into the vectorization context. |
![]() |
Text(Point3d, Vector3d, Vector3d, Double, Double, Double, String) | Introduces text into the vectorization context. |
![]() |
![]() |
WorldLine | Introduces a line into the vectorization context. |
![]() |
![]() |
Xline | Introduces an xline into the vectorization context. |
© Bricsys NV. All rights reserved. |