MaterialDiffuseComponentEquality
Operator
|
Equality operator for the
MaterialDiffuseComponent structure. Checks whether input diffuse
components are equal.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static bool operator ==(
MaterialDiffuseComponent a,
MaterialDiffuseComponent b
)
Public Shared Operator = (
a As MaterialDiffuseComponent,
b As MaterialDiffuseComponent
) As Boolean
public:
static bool operator ==(
MaterialDiffuseComponent a,
MaterialDiffuseComponent b
)
static let inline (=)
a : MaterialDiffuseComponent *
b : MaterialDiffuseComponent : bool
Parameters
- a MaterialDiffuseComponent
- [in] Left diffuse component to compare.
- b MaterialDiffuseComponent
- [in] Right diffuse component to compare.
Return Value
Boolean
true only if the following conditions are met: * Material map of
the left diffuse component is identical to the material map of the
right diffuse component (both can be nullptr). * Material color of
the left diffuse component is identical to the material color of
the right diffuse component (both can be nullptr).
See Also