Material
|
The MaterialDiffuseComponent type exposes the following members.
Name | Description | |
---|---|---|
![]() |
MaterialDiffuseComponent | Constructor for the MaterialDiffuseComponent class. Constructs an object with the specified material color and material map. |
Name | Description | |
---|---|---|
![]() |
Equals | Checks objects for equality. (Overrides ValueTypeEquals(Object)) |
![]() |
GetHashCode | Retrieves the object hash code. (Overrides ValueTypeGetHashCode) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
ToString | Returns an equivalent string representation of this
object. (Overrides ValueTypeToString) |
![]() |
ToString(IFormatProvider) | Returns an equivalent string representation of this object. |
Name | Description | |
---|---|---|
![]() ![]() |
Equality(MaterialDiffuseComponent, MaterialDiffuseComponent) | Equality operator for the MaterialDiffuseComponent structure. Checks whether input diffuse components are equal. |
![]() ![]() |
Inequality(MaterialDiffuseComponent, MaterialDiffuseComponent) | Inequality operator for the MaterialDiffuseComponent structure. Checks whether input diffuse components are not equal. |
© Bricsys NV. All rights reserved. |