AssocVariableCallbackValidateNameAndExpression Method

Validates the specified name, expression or both, to check whether they can be used for this variable.

Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public abstract string ValidateNameAndExpression(
        AssocVariable variable,
        string nameToValidate,
        string expressionToValidate
)

Parameters

variable  AssocVariable
[in] Variable for which name and expression can be validated.
nameToValidate  String
[in] Variable name to validate. Can be null.
expressionToValidate  String
[in] Expression to validate. Can be null.

Return Value

String
Remarks
String with an error message, if errors occur or an empty string otherwise.
See Also

©  Bricsys NV. All rights reserved.