Curve3dIsPeriodic Method

Checks whether the curve is periodic.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public bool IsPeriodic(
        out double period
)

Parameters

period  Double
[out] Period of the curve parameter.

Return Value

Boolean
true if this curve is periodic, false otherwise.
Remarks
The curve is periodic only if it is closed and returned values for evalPoint(t) and evalPoint(t+period) are always the same for any passed parameter t.
See Also

©  Bricsys NV. All rights reserved.