Scales this point by the scale factor about
the specified point.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point2d ScaleBy(
double scaleFactor,
Point2d origin
)
Public Function ScaleBy (
scaleFactor As Double,
origin As Point2d
) As Point2d
public:
Point2d ScaleBy(
double scaleFactor,
Point2d origin
)
member ScaleBy :
scaleFactor : float *
origin : Point2d -> Point2d
Parameters
- scaleFactor Double
- [in] Scale factor.
- origin Point2d
- [in] Point relative to which scaling is computed.
Return Value
Point2d
2D point that is the result of the scale operation.
See Also