CompositeCurve2d Constructor
|
Constructor for the OdGeCompositeCurve2d
class. Creates a composite curve from the given array of curves.
Curves in the passed array must be connected at their endpoints.
This means that the start point of each curve in the array (except
the first curve) should coincide with the endpoint of the previous
curve in the array.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public CompositeCurve2d(
Curve2d[] curves
)
Public Sub New (
curves As Curve2d()
)
public:
CompositeCurve2d(
array<Curve2d^>^ curves
)
new :
curves : Curve2d[] -> CompositeCurve2d
Parameters
- curves Curve2d
- Array of curves from which this composite curve is
constructed.
See Also