Curve2d Class

This .NET class wraps the OdGeCurve2d class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        Teigha.GeometryCurve2d
          More

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class Curve2d : Entity2d

The Curve2d type exposes the following members.

Properties
Methods
  Name Description
Public methodStatic member Create Creates a Curve2d object based on the passed pointer.
Public method EvaluatePoint Retrieves the point on the curve corresponding to the specified parameter value.
Public method Explode Explodes the curve into its component sub-curves.
Public method GetArea(Double, Double) Retrieves the area of the parametric interval defined by the passed start and end parameters.
Public method GetArea(Double, Double, Tolerance) Retrieves the area of the parametric interval defined by the passed start and end parameters within the specified tolerance.
Public method GetBoundBlockOf Retrieves the oriented bounding box of the specified parametric interval of this curve.
Public method GetClosestPointTo(Curve2d) Retrieves the closest points between this curve and the passed curve.
Public method GetClosestPointTo(Point2d) Retrieves the closest point on this curve to the specified point.
Public method GetClosestPointTo(Curve2d, Tolerance) Retrieves the closest points between this curve and the passed curve within a specified tolerance.
Public method GetClosestPointTo(Point2d, Tolerance) Retrieves the closest point on this curve to the specified point within the specified tolerance.
Public method GetDistanceTo(Curve2d) Retrieves the distance of the closest points between this curve and the passed curve.
Public method GetDistanceTo(Point2d) Retrieves the distance of the closest point on this curve and the specified point.
Public method GetDistanceTo(Curve2d, Tolerance) Retrieves the distance of the closest points between this curve and the passed curve within a specified tolerance.
Public method GetDistanceTo(Point2d, Tolerance) Retrieves the distance of the closest point on this curve and the specified point within a specified tolerance.
Public method GetInterval Retrieves the parametric interval of this curve.
Public method GetLength(Double, Double) Retrieves the arc length of the curve between the two parameter values.
Public method GetLength(Double, Double, Tolerance) Retrieves the arc length of the curve between the two parameter values within a specified tolerance.
Public method GetNormalPoint(Point2d) Retrieves the point on this curve where normal extends through the passed point.
Public method GetNormalPoint(Point2d, Tolerance) Retrieves the point on this curve where normal extends through the passed point within the specified tolerance.
Public method GetOrthoBoundBlockOf Retrieves the bounding box of the specified parametric range of this curve. Bounding box sides are parallel to the coordinate axes.
Public method GetParameterAtLength(Double, Double, Boolean) Retrieves the parameter value of the point whose arc length distance is the input length.
Public method GetParameterAtLength(Double, Double, Boolean, Tolerance) Retrieves the parameter value of the point whose arc length distance is the input length.
Public method GetParameterOf(Point2d) Retrieves the parameter value of a point.
Public method GetParameterOf(Point2d, Tolerance) Retrieves the parameter value of a point within a specified tolerance.
Public method GetReverseParameterCurve Reverses the parameter direction for this curve.
Public method GetSamplePoints(Int32) Retrieves an array of sample points along this curve.
Public method GetSamplePoints(Double, Double, Double) Retrieves specified arrays of sample points along this curve and their parameter values.
Public method GetSplitCurves Retrieves two segments of this curve split at the specified parameter value.
Public method GetTrimmedOffset(Double, OffsetCurveExtensionType) Retrieves offset curves that represent the trimmed offset of the curve.
Public method GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) Retrieves one or more offset curves that represent the trimmed offset of the curve.
Public method IsClosed Checks whether the curve is closed.
Public method IsClosed(Tolerance) Checks whether the curve is closed within a specified tolerance.
Public method IsDegenerate(Entity2d) Checks whether this curve is degenerate and returns the type of entity that the curve degenerates to (if degenerate).
Public method IsDegenerate(Entity2d, Tolerance) Checks whether this curve is degenerate and returns the type of entity that the curve degenerates to (if degenerate).
Public method IsLinear(Line2d) Checks whether this curve is linear.
Public method IsLinear(Line2d, Tolerance) Checks whether this curve is linear within a specified tolerance.
Public method IsOn(Double) Checks whether a specified parameter value is within a valid parametric range of the curve.
Public method IsOn(Point2d) Checks whether a specified point lies on this curve.
Public method IsOn(Double, Tolerance) Checks whether a specified parameter value is within a parametric range of the curve.
Public method IsOn(Point2d, Double) Checks whether a specified point lies on this curve.
Public method IsOn(Point2d, Tolerance) Checks whether a specified point lies on this curve within specified tolerance.
Public method IsOn(Point2d, Double, Tolerance) Checks whether a specified point lies on this curve.
Public method IsPeriodic Checks whether the curve is periodic.
Public method SetInterval Sets the parametric range of this curve.
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        Teigha.GeometryCurve2d
          Teigha.GeometryCircularArc2d
          Teigha.GeometryCompositeCurve2d
          Teigha.GeometryEllipticalArc2d
          Teigha.GeometryExternalCurve2d
          Teigha.GeometryLinearEntity2d
          Teigha.GeometryOffsetCurve2d
          Teigha.GeometrySplineEntity2d

©  Bricsys NV. All rights reserved.