Creates a 3D solid object by thickening the
surface by a specified amount.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual Solid3d Thicken(
double thickness,
bool bothSides
)
Public Overridable Function Thicken (
thickness As Double,
bothSides As Boolean
) As Solid3d
public:
virtual Solid3d^ Thicken(
double thickness,
bool bothSides
)
abstract Thicken :
thickness : float *
bothSides : bool -> Solid3d
override Thicken :
thickness : float *
bothSides : bool -> Solid3d
Parameters
- thickness Double
- [in] Amount to thicken the surface.
- bothSides Boolean
- [in] Flag that specifies whether the thickening should be
applied to both sides of the surface.
Return Value
Solid3d
Solid3d object created during the thickening. Can be NULL if the
method fails.
Remarks
If the thickness
is less than zero, the surface is thickened in the opposite
direction. This method is implemented only for the Spatial
modeler.
See Also