SurfaceBooleanSubtract(Solid3d)
Method
|
Performs a Boolean subtraction operation
between this surface and the specified solid object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual Surface BooleanSubtract(
Solid3d solid
)
Public Overridable Function BooleanSubtract (
solid As Solid3d
) As Surface
public:
virtual Surface^ BooleanSubtract(
Solid3d^ solid
)
abstract BooleanSubtract :
solid : Solid3d -> Surface
override BooleanSubtract :
solid : Solid3d -> Surface
Parameters
- solid Solid3d
- [in] Solid object to be subtracted from this surface.
Return Value
Surface
Surface that represents the subtraction operation result.
Remarks
This method is
implemented only for the ModelerGeometry and Spatial modelers. If
this surface is not derived from the Surface class, the result is
stored in this surface. Otherwise, this surface is not changed and
the resulting surface is returned by the method. If the resulting
surface is empty, the method throws the eNoIntersections exception,
returns NULL, and this surface is not changed. If the subtraction
operation fails, the method returns NULL, and this surface is not
changed.
See Also