MaterialNormalMapComponentInequality Operator

Inequality operator for the MaterialNormalMapComponent structure. Checks whether input normal map components are not equal.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public static bool operator !=(
        MaterialNormalMapComponent a,
        MaterialNormalMapComponent b
)

Parameters

a  MaterialNormalMapComponent
[in] Left normal map component to compare.
b  MaterialNormalMapComponent
[in] Right normal map component to compare.

Return Value

Boolean
true if at least one of the following conditions fails: * Methods used to calculate normal maps are equal (both can be nullptr). * Strength values of normal maps are equal.
See Also

©  Bricsys NV. All rights reserved.