Curve3dGetParameterAtLength
Method
|
Retrieves the parameter value of the point
whose arc length distance is the input length.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public double GetParameterAtLength(
double datumParameter,
double length,
bool direction,
double tolerance
)
Public Function GetParameterAtLength (
datumParameter As Double,
length As Double,
direction As Boolean,
tolerance As Double
) As Double
public:
double GetParameterAtLength(
double datumParameter,
double length,
bool direction,
double tolerance
)
member GetParameterAtLength :
datumParameter : float *
length : float *
direction : bool *
tolerance : float -> float
Parameters
- datumParameter Double
- [in] Parameter value.
- length Double
- [in] Sub-interval of the curve.
- direction Boolean
- [in] Parameter direction.
- tolerance Double
- [in] Geometric tolerance.
Return Value
Double
Parameter value as the
double type.
See Also