SurfaceSurfaceIntersectorGetDimension Method

Returns the dimension of the intersection point by its index.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public int GetDimension(
        int number
)

Parameters

number  Int32
[in] The zero-based index of the intersection.

Return Value

Int32
* 0 - Represents an intersection point. * 1 - Represents an intersection curve.
Remarks
This method throws one of the following exceptions if the method fails: * kXXIndexOutOfRange - Index out of range. * kXXUnknown - Intersector is not initialized.
See Also

©  Bricsys NV. All rights reserved.