Creates a mesh of a sphere.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetTorus(
double majorRadius,
int divSection,
int divSweepPath,
double sectionRadiusRatio,
double sectionRotate,
int smoothLevel
)
Public Sub SetTorus (
majorRadius As Double,
divSection As Integer,
divSweepPath As Integer,
sectionRadiusRatio As Double,
sectionRotate As Double,
smoothLevel As Integer
)
public:
void SetTorus(
double majorRadius,
int divSection,
int divSweepPath,
double sectionRadiusRatio,
double sectionRotate,
int smoothLevel
)
member SetTorus :
majorRadius : float *
divSection : int *
divSweepPath : int *
sectionRadiusRatio : float *
sectionRotate : float *
smoothLevel : int -> unit
Parameters
- majorRadius Double
- [in] Major radius of a torus.
- divSection Int32
- [in] Specifies how many divisions are made for the base
circle.
- divSweepPath Int32
- [in] Specifies how many divisions are made along the torus'
path.
- sectionRadiusRatio Double
- [in] Ratio of major to minor radii.
- sectionRotate Double
- [in] Angle of section rotation.
- smoothLevel Int32
- [in] Level of smoothness.
See Also