FieldCodeFlags Enumeration
|
Represents field code flags.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
[FlagsAttribute]
public enum FieldCodeFlags
<FlagsAttribute>
Public Enumeration FieldCodeFlags
[FlagsAttribute]
public enum class FieldCodeFlags
[<FlagsAttribute>]
type FieldCodeFlags
Members
Member name |
Value |
Description |
FieldCode |
1 |
Represents the raw field code. This flag is not applicable when
setting the field code. |
EvaluatedText |
2 |
Represents the evaluated text. This flag is not applicable when
setting the field code. |
EvaluatedChildren |
4 |
Represents the field code with evaluated text for children.
This flag is combined with FieldCode. This flag is not applicable
when setting the field code. |
ObjectReference |
8 |
Represents the embedded fields in the text as references to
nested fields stored in the ChildFields
argument. This flag is valid only for text fields and is used for
editing. This flag is not applicable when setting the field
code. |
AddMarkers |
16 |
|
EscapeBackslash |
32 |
If set, all backslashes are escaped using another backslash
(i.e., each single backslash is converted to a double backslash) in
the evaluated text. When retrieving the field code, can be combined
with EvaluatedText or EvaluatedChildren. |
StripOptions |
64 |
If set, the standard options like evaluator ID, format, and
hyperlink data are stripped from the field code. This flag can be
combined with FieldCode or EvaluatedChildren. This flag is not applicable when
setting the field code. |
PreserveFields |
128 |
For internal use. This flag is not applicable when retrieving
the field code. |
TextField |
256 |
If this flag is set, the field code is treated as text with
embedded fields. This flag is not applicable when retrieving the
field code. |
See Also