TransparencyCollection Class

Wraps OdCmTransparencyArray. Represents a collection of Transparency objects.
Inheritance Hierarchy
SystemObject
  Teigha.ColorsTransparencyCollection

Namespace: Teigha.Colors
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class TransparencyCollection : IList

The TransparencyCollection type exposes the following members.

Constructors
  Name Description
Public method TransparencyCollection Default constructor. Creates new TransparencyCollection object with DefaultSize.
Public method TransparencyCollection(Int32) Builds a new instance of TransparencyCollection class with specific capacity.
Public method TransparencyCollection(Transparency) Builds a new instance of TransparencyCollection class using array of Transparency objects.
Top
Properties
  Name Description
Public property Capacity Gets or sets the number of elements that the TransparencyCollection can contain.
Public property Count Gets the number of elements actually contained in the TransparencyCollection.
Public property IsFixedSize Gets a value indicating whether the TransparencyCollection has a fixed size.
Public property IsReadOnly Gets a value indicating whether the TransparencyCollection is read-only.
Public property IsSynchronized Gets a value indicating whether access to the TransparencyCollection is synchronized (thread safe).
Public property Item Gets or sets the element at the specified index in the TransparencyCollection.
Public property SyncRoot Gets an object that can be used to synchronize access to the TransparencyCollection.
Top
Methods
  Name Description
Public method Add Adds an Transparency object to the collection.
Public method AddRange Adds an array of Transparency objects to the collection.
Public method Clear Removes all objects from the collection.
Public method Contains Determines whether the specified Transparency object is a member of the collection.
Public method Copy Copies a range of elements from a source Transparency array starting at the specified source index and pastes them into destination Transparency array starting at the specified destination index. The length is specified as a 32-bit integer.
Public method CopyTo Copies the entire contents of this TransparencyCollection to a compatible one-dimensional array, starting at the specified index of the target array.
Public method GetEnumerator Returns an enumerator for the entire TransparencyCollection.
Public method IndexOf Determines the index of a specific item in the collection.
Public method Insert Inserts a Transparency object to the collection at the specified index.
Public method Remove Removes the first occurrence of a specific object from the TransparencyCollection
Public method RemoveAt Removes the TransparencyCollection item at the specified index.
Public method ToArray Creates an array of Transparency objects from the TransparencyCollection.
Public method TrimToSize Sets the capacity to the actual number of elements in the TransparencyCollection.
Top
See Also

©  Bricsys NV. All rights reserved.