TableStyleOverride Enumeration

This enum class specifies how text is aligned in a table cell. These values are relevant when text is oriented horizontally.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public enum TableStyleOverride
Members
Member name Value Description
TitleSuppressed 1 Title suppressed table style override.
HeaderSuppressed 2 Header suppressed table style override.
FlowDirection 3 Flow direction table style override.
HorizontalCellMargin 4 Horizontal cell margin table style override.
VerticalCellMargin 5 Vertical cell margin table style override.
TitleRowColor 6 Title row color table style override.
HeaderRowColor 7 Header row color table style override.
DataRowColor 8 Data row color table style override.
TitleRowFillNone 9 Title row no fill table style override.
HeaderRowFillNone 10 Header row no fill table style override.
DataRowFillNone 11 Data row no fill table style override.
TitleRowFillColor 12 Title row fill color table style override.
HeaderRowFillColor 13 Header row fill color table style override.
DataRowFillColor 14 Data row fill color table style override.
TitleRowAlignment 15 Title row alignment table style override.
HeaderRowAlignment 16 Header row alignment table style override.
DataRowAlignment 17 Data row alignment table style override.
TitleRowTextStyle 18 Title row text style table style override.
HeaderRowTextStyle 19 Header row text style table style override.
DataRowTextStyle 20 Data row text style table style override.
TitleRowTextHeight 21 Title row text height table style override.
HeaderRowTextHeight 22 Header row text height table style override.
DataRowTextHeight 23 Data row text height table style override.
TitleRowDataType 24 Title row data type. For internal use.
HeaderRowDataType 25 Header row data type. For internal use.
DataRowDataType 26 Data row data type. For internal use.
TitleHorizontalTopColor 40 Row horizontal top gridline color table style override.
TitleHorizontalInsideColor 41 Row horizontal inside gridline color table style override.
TitleHorizontalBottomColor 42 Title row horizontal bottom gridline color table style override.
TitleVerticalLeftColor 43 Title row vertical left gridline color table style override.
TitleVerticalInsideColor 44 Title row vertical inside gridline color table style override.
TitleVerticalRightColor 45 Title row vertical right gridline color table style override.
HeaderHorizontalTopColor 46 Header row horizontal top gridline color table style override.
HeaderHorizontalInsideColor 47 Header row horizontal inside gridline color table style override.
HeaderHorizontalBottomColor 48 Header row horizontal bottom gridline color table style override.
HeaderVerticalLeftColor 49 Header row vertical left gridline color table style override.
HeaderVerticalInsideColor 50 Header row vertical inside gridline color table style override.
HeaderVerticalRightColor 51 Header row vertical right gridline color table style override.
DataHorizontalTopColor 52 Data row horizontal top gridline color table style override.
DataHorizontalInsideColor 53 Data row horizontal inside gridline color table style override.
DataHorizontalBottomColor 54 Data row horizontal bottom gridline color table style override.
DataVerticalLeftColor 55 Data row vertical left gridline color table style override.
DataVerticalInsideColor 56 Data row vertical inside gridline color table style override.
DataVerticalRightColor 57 Data row vertical right gridline color table style override.
TitleHorizontalTopLineWeight 70 Title row horizontal top gridline lineweight table style override.
TitleHorizontalInsideLineWeight 71 Title row horizontal inside gridline lineweight table style override.
TitleHorizontalBottomLineWeight 72 Title row horizontal bottom gridline lineweight table style override.
TitleVerticalLeftLineWeight 73 Title row vertical left gridline lineweight table style override.
TitleVerticalInsideLineWeight 73 Title row vertical inside gridline lineweight table style override.
TitleVerticalRightLineWeight 75 Title row vertical right gridline lineweight table style override.
HeaderHorizontalTopLineWeight 76 Header row horizontal top gridline lineweight table style override.
HeaderHorizontalInsideLineWeight 77 Header row horizontal inside gridline lineweight table style override.
HeaderHorizontalBottomLineWeight 78 Header row horizontal bottom gridline lineweight table style override.
HeaderVerticalLeftLineWeight 79 Header row vertical left gridline lineweight table style override.
HeaderVerticalInsideLineWeight 80 Header row vertical inside gridline lineweight table style override.
HeaderVerticalRightLineWeight 81 Header row vertical right gridline lineweight table style override.
DataHorizontalTopLineWeight 82 Data row horizontal top gridline lineweight table style override.
DataHorizontalInsideLineWeight 83 Data row horizontal inside gridline lineweight table style override.
DataHorizontalBottomLineWeight 84 Data row horizontal bottom gridline lineweight table style override.
DataVerticalLeftLineWeight 85 Data row vertical left gridline lineweight table style override.
DataVerticalInsideLineWeight 86 Data row vertical inside gridline lineweight table style override.
DataVerticalRightLineWeight 87 Data row vertical right gridline lineweight table style override.
TitleHorizontalTopVisibility 100 Title row horizontal top gridline visibility table style override.
TitleHorizontalInsideVisibility 101 Title row horizontal inside gridline visibility table style override.
TitleHorizontalBottomVisibility 102 Title row horizontal bottom gridline visibility table style override.
TitleVerticalLeftVisibility 103 Title row vertical left gridline visibility table style override.
TitleVerticalInsideVisibility 104 Title row vertical inside gridline visibility table style override.
TitleVerticalRightVisibility 105 Title row vertical right gridline visibility table style override.
HeaderHorizontalTopVisibility 106 Header row horizontal top gridline visibility table style override.
HeaderHorizontalInsideVisibility 107 Header row horizontal inside gridline visibility table style override.
HeaderHorizontalBottomVisibility 108 Header row horizontal bottom gridline visibility table style override.
HeaderVerticalLeftVisibility 109 Header row vertical left gridline visibility table style override.
HeaderVerticalInsideVisibility 110 Header row vertical inside gridline visibility table style override.
HeaderVerticalRightVisibility 111 Header row vertical right gridline visibility table style override.
DataHorizontalTopVisibility 112 Data row horizontal top gridline visibility table style override.
DataHorizontalInsideVisibility 113 Data row horizontal inside gridline visibility table style override.
DataHorizontalBottomVisibility 114 Data row horizontal bottom gridline visibility table style override.
DataVerticalLeftVisibility 115 Data row vertical left gridline visibility table style override.
DataVerticalInsideVisibility 116 Data row vertical inside gridline visibility table style override.
DataVerticalRightVisibility 117 Data row vertical right gridline visibility table style override.
CellAlignment 130 Alignment table style override for table cell.
CellBackgroundFillNone 131 Background no fill table style override for table cell.
CellBackgroundColor 132 Background color table style override for table cell.
CellContentColor 133 Content color table style override for table cell.
CellTextStyle 134 Text style table style override for table cell.
CellTextHeight 135 Text height table style override for table cell.
CellTopGridColor 136 Top edge grid color table style override for table cell.
CellRightGridColor 137 Right edge grid color table style override for table cell.
CellBottomGridColor 138 Bottom edge grid color table style override for table cell.
CellLeftGridColor 139 Left edge grid color table style override for table cell.
CellTopGridLineWeight 140 Top edge grid lineweight table style override for table cell.
CellRightGridLineWeight 141 Right edge grid lineweight table style override for table cell.
CellBottomGridLineWeight 142 Bottom edge grid lineweight table style override for table cell.
CellLeftGridLineWeight 143 Left edge grid lineweight table style override for table cell.
CellTopVisibility 144 Top edge grid visibility table style override for table cell.
CellRightVisibility 145 Right edge grid visibility table style override for table cell.
CellBottomVisibility 146 Bottom edge grid visibility table style override for table cell.
CellLeftVisibility 147 Left edge grid visibility table style override for table cell.
CellDataType 148 Data type of a cell.
See Also

©  Bricsys NV. All rights reserved.