AssocNetworkGetInstanceFromObject
Method
|
Returns an object ID of the associated network
owned by the extension dictionary of the given object. It
optionally creates a new sub-dictionary and a new network if they
do not exist yet.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public static ObjectId GetInstanceFromObject(
ObjectId owningObjectId,
bool createIfDoesNotExist,
bool addToTopLevelNetwork,
string dictionaryKey
)
Public Shared Function GetInstanceFromObject (
owningObjectId As ObjectId,
createIfDoesNotExist As Boolean,
addToTopLevelNetwork As Boolean,
dictionaryKey As String
) As ObjectId
public:
static ObjectId GetInstanceFromObject(
ObjectId owningObjectId,
bool createIfDoesNotExist,
bool addToTopLevelNetwork,
String^ dictionaryKey
)
static member GetInstanceFromObject :
owningObjectId : ObjectId *
createIfDoesNotExist : bool *
addToTopLevelNetwork : bool *
dictionaryKey : string -> ObjectId
Parameters
- owningObjectId ObjectId
- [in] Object ID of the object to take the associative network
from.
- createIfDoesNotExist Boolean
- [in] Specifies whether to create a new subdictionary under the
named object dictionary of the database.
- addToTopLevelNetwork Boolean
- [in] Specifies whether to add the link to created network to
top level network.
- dictionaryKey String
- [in] The name of the sub-dictionary under which the network
belongs. If the this parameter is empty, the default dictionary is
used.
Return Value
ObjectId
Object identifier of the existing or newly created associative
network.
See Also