SplineToPolyline(UInt32) Method
|
Generates a polyline to approximate a
spline.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Curve ToPolyline(
uint numOfVertices
)
Public Function ToPolyline (
numOfVertices As UInteger
) As Curve
public:
Curve^ ToPolyline(
unsigned int numOfVertices
)
member ToPolyline :
numOfVertices : uint32 -> Curve
Parameters
- numOfVertices UInt32
- [in] Vertices threshold value. The resulting polyline's vertex
count does not exceed this value.
Return Value
Curve
Polyline from this spline.
Remarks
The resulting
curve can be a Polyline, Polyline2d, or Polyline3d type. If at
least one of the points of the spline does not lie on the XY plane,
a Polyline3d is created from linear segments.
See Also