Scale3dRemoveScale
Method
|
Returns the scale vector corresponding to the
lengths of the column vectors of the transformation matrix, and
sets the scale factor of the matrix to 1 ..
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static Scale3d RemoveScale(
Matrix3d mat
)
Public Shared Function RemoveScale (
mat As Matrix3d
) As Scale3d
public:
static Scale3d RemoveScale(
Matrix3d mat
)
static member RemoveScale :
mat : Matrix3d -> Scale3d
Parameters
- mat Matrix3d
- [in/out] Transformation matrix to modify.
Return Value
Scale3d
See Also