Scale3d Structure

This structure represents scaling transformations (scale vectors) in 3D space. The Scale2d may be viewed as an array[3] of doubles. Array indecies: * 0 - scale factor for X axis * 1 - scale factor for Y axis * 2 - scale factor for Z axis
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryScale3d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Scale3d

The Scale3d type exposes the following members.

Constructors
  Name Description
Public method Scale3d(Double) Constructor for the Scale3d class. Creates scale transformation with the uniform scale factor.
Public method Scale3d(Double) Constructor for the Scale3d class. Creates scale transformation with the specified factors for x, y and z axes.
Public method Scale3d(Double, Double, Double) Constructor for the Scale3d class. Creates scale transformation with the specified factors for x and y axes.
Top
Properties
  Name Description
Public property Coordinate Property that represents a scale factor at the specified index.
Public property X Property that represents a scale factor for the x axis.
Public property Y Property that represents a scale factor for the y axis.
Public property Z Property that represents a scale factor for the z axis.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public methodStatic member ExtractScale Returns the scale that corresponds to the lengths of the column vectors of the specified transformation matrix.
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method GetMatrix Returns the transformation matrix equivalent to this scale vector.
Public method Inverse Returns the inverse of this scale vector.
Public method IsEqualTo(Scale3d) Checks whether the specified scale vector equals to this scale vector.
Public method IsEqualTo(Scale3d, Tolerance)  
Public method IsProportional Checks whether this scale vector scales uniformly.
Public method IsProportional(Tolerance) Checks whether this scale vector scales uniformly according to the specified tolerance.
Public method MultiplyBy Multiplies this scale vector by the specified scale factor and returns the resulting scale vector.
Public method PostMultiplyBy Sets this scale vector to the product (this scale vector) * (rightSide), and returns the resulting vector.
Public method PreMultiplyBy Sets this scale vector to the product (rightSide) * (this scale vector), and returns the resulting vector.
Public methodStatic member RemoveScale Returns the scale vector corresponding to the lengths of the column vectors of the transformation matrix, and sets the scale factor of the matrix to 1 ..
Public method ToArray Returns an array of 3 values that represent scale factors for x, y and z axes.
Public method ToString Returns a string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns a string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(Scale3d, Scale3d) Equality operator for the Scale3d class.
Public operatorStatic member Inequality(Scale3d, Scale3d) Inequality operator for the Scale3d class.
Public operatorStatic member Multiply(Double, Scale3d) Multiplication operator for the Scale3d class. Multiplies a scale factor by the specified scale vector and returns the resulting vector.
Public operatorStatic member Multiply(Scale3d, Double) Multiplication operator for the Scale3d class. Multiplies a scale vector by the specified scale factor and returns the resulting vector.
Public operatorStatic member Multiply(Scale3d, Scale3d) Multiplication operator for the Scale3d class. Multiplies left scale vector by the right scale vector (a*b) and returns the resulting vector.
Top
See Also

©  Bricsys NV. All rights reserved.