DuplicateRecordCloning Enumeration
|
Determines what actions are performed if
symbols or dictionary entries are cloned and a duplicate is found
in the destination database.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum DuplicateRecordCloning
Public Enumeration DuplicateRecordCloning
public enum class DuplicateRecordCloning
type DuplicateRecordCloning
Members
Member name |
Value |
Description |
NotApplicable |
0 |
Not applicable to the object. |
Ignore |
1 |
If a duplicate record exists, use the existing record in the
database, and ignore the clone. |
Replace |
2 |
If a duplicate record exists, replace it with the cloned
record. |
RefMangleName |
3 |
|
MangleName |
4 |
|
UnmangleName |
5 |
Unmangle the names mangled by kDrcMangleName, then default to
kDrcIgnore. Typically used by RefEdit when checking records into
the original database. |
See Also