Represents lineweights in 100ths of a
millimeter, except special negative values that indicate that the
lineweight is either set by owner block, set by owner layer, or
defined by the LWDEFAULT system variable.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
[TypeConverterAttribute(typeof(LineWeightConverter))]
public enum LineWeight
<TypeConverterAttribute(GetType(LineWeightConverter))>
Public Enumeration LineWeight
[TypeConverterAttribute(typeof(LineWeightConverter))]
public enum class LineWeight
[<TypeConverterAttribute(typeof(LineWeightConverter))>]
type LineWeight
Members
Member name |
Value |
Description |
LineWeight000 |
0 |
|
LineWeight005 |
5 |
|
LineWeight009 |
9 |
|
ByLayer |
-1 |
|
LineWeight013 |
13 |
|
LineWeight015 |
15 |
|
LineWeight018 |
18 |
|
ByBlock |
-2 |
|
LineWeight020 |
20 |
|
LineWeight025 |
25 |
|
ByLineWeightDefault |
-3 |
|
LineWeight030 |
30 |
|
LineWeight035 |
35 |
|
LineWeight040 |
40 |
|
LineWeight050 |
50 |
|
LineWeight053 |
53 |
|
LineWeight060 |
60 |
|
LineWeight070 |
70 |
|
LineWeight080 |
80 |
|
LineWeight090 |
90 |
|
LineWeight100 |
100 |
|
LineWeight106 |
106 |
|
LineWeight120 |
120 |
|
LineWeight140 |
140 |
|
LineWeight158 |
158 |
|
LineWeight200 |
200 |
|
LineWeight211 |
211 |
|
See Also