LinkedTableDataGetBlockAttributeValue
Method
|
Returns the attribute value of the block cell
using the specified object ID key as a string.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual string GetBlockAttributeValue(
int row,
int column,
ObjectId attributeDefinitionId
)
Public Overridable Function GetBlockAttributeValue (
row As Integer,
column As Integer,
attributeDefinitionId As ObjectId
) As String
public:
virtual String^ GetBlockAttributeValue(
int row,
int column,
ObjectId attributeDefinitionId
)
abstract GetBlockAttributeValue :
row : int *
column : int *
attributeDefinitionId : ObjectId -> string
override GetBlockAttributeValue :
row : int *
column : int *
attributeDefinitionId : ObjectId -> string
Parameters
- row Int32
- [in] Row index of the cell.
- column Int32
- [in] Column index of the cell.
- attributeDefinitionId ObjectId
- [in] Object ID.
Return Value
String
Remarks
The method
generates the eInvalidInput exception
when the input row number and column number are less than 0 or
greater than the table size.
See Also