Specifies which actions are performed to
calculate intersections between entities.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
Public Enumeration Intersect
public enum class Intersect
Members
Member name |
Value |
Description |
OnBothOperands |
0 |
Do not extend bounding box edges for both intersecting
entities. This method calculates intersections only where the
bounding box lines actually intersect. |
ExtendThis |
1 |
Extend bounding box edges of this entity, if necessary, when
calculating intersections. The bounding box of the second entity
(which is passed as an argument) is not extended. |
ExtendArgument |
2 |
Extend bounding box edges of the other entity (which is passed
as an argument),if necessary, when calculating intersections. The
bounding box of this entity is not extended. |
ExtendBoth |
3 |
Extend bounding box edges for both intersecting entities, if
necessary. |
See Also