Creates a Curve3d object based on the passed
pointer.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static Curve3d Create(
NativeObjectBase* nativeObject
)
Visual Basic does not support APIs that consume or return unsafe types.
public:
static Curve3d^ Create(
NativeObjectBase* nativeObject
)
F# does not support APIs that consume or return unsafe types.
Parameters
- nativeObject NativeObjectBase*
- [in] Input pointer to the native object from which this object
is created.
Return Value
Curve3d
Returns the created object.
Remarks
NativeObjectBase
is expected to be constructed by Wrapped::Create methods; use
CreateRaw or CreateShared, depending on if you should use existing
shared_ptr or only native object. If you have received shared_ptr
from native code, pass it here by CreateShared.
See Also