MaterialOpacityComponent Structure

This structure stores the opacity component (channel) for the material.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GraphicsInterfaceMaterialOpacityComponent

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct MaterialOpacityComponent

The MaterialOpacityComponent type exposes the following members.

Constructors
  Name Description
Public method MaterialOpacityComponent Constructor for the MaterialOpacityComponent structure. Constructs an object with the specified opacity percentage and material map (that defines how opacity values are mapped).
Top
Properties
  Name Description
Public property Map  
Public property Percentage  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method ToString Returns an equivalent string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(MaterialOpacityComponent, MaterialOpacityComponent) Equality operator for the MaterialOpacityComponent structure. Checks whether input opacity components are equal.
Public operatorStatic member Inequality(MaterialOpacityComponent, MaterialOpacityComponent) Inequality operator for the MaterialOpacityComponent structure. Checks whether input opacity components are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.