PolylineGetSegmentType Method

Returns the type of the specified segment of this polyline entity.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public SegmentType GetSegmentType(
        int index
)

Parameters

index  Int32
[in] Segment index.

Return Value

SegmentType
Returns one of the following: Name Description Line Straight segment with length > 0.0. Arc Arc segment with length > 0.0. Coincident Segment with length == 0.0. Point Polyline with 1 vertex. Empty Polyline with 0 vertices.
See Also

©  Bricsys NV. All rights reserved.